สนใจลงโฆษณา คลิกที่นี่

ผู้เขียน หัวข้อ: อยากเอา10กระทู้แรกไปแทรกหน้าแรกของเวปต้องทำไงครับ  (อ่าน 3251 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ kajohnsak

  • New Member
  • *
  • กระทู้: 2
    • ดูรายละเอียด
อยากเอา10กระทู้แรกไปแทรกหน้าแรกของเวปต้องทำไงครับ ตอนนี้ผมใช้ wordpress เขียนเวปมาเวปนึง แล้วผมก็ใช้ smf เป็น webboard ของเวปผม และที่ผมต้องการคือผม อยากจะให้กระทู้ 10 กระทู้แรกล่าสุดไปอยู่ที่ หน้าแรกหน้าเดียวของเวป ผมจะต้องใช้ code อะไร และแทรกไปที่ไหน บรรทัดไหนอะครับขอผู้รู้ช่วยตอบผมหน่อยนะครับ ขอบคุณครับ

ออฟไลน์ chaotoob.com

  • Jr. Member
  • **
  • กระทู้: 74
    • ดูรายละเอียด
เริ่มต้นท่านก็สร้าง showtopic.php มาก่อนเลยครับแล้วนำ Code ข้างล่างนี้ไปวาง (บอกก่อน xxxx คือชื่อเว็บของท่านนะครับ อย่าลิมเปลี่ยนด้วยละ)

แล้วส่วนที่ต้องเพิ่มก็คือ <?php ssi_recentPosts(ใส่ตามที่ต้องการว่าจะโชว์กี่กระทู้ 5 หรือ 10 ก็ว่ากันไป); ?>


โค้ด: [เลือก]
<?php require("/home/xxxx/domains/xxxx.com/public_html/forum/SSI.php"); ?>
 <?php require("SSI.php"); ?>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Showtopic</title>
<base target="_blank">
<style type="text/css">
<!--
body{
margin-top:0px;
margin-bottom:2px;
background-color: #FFFFFF;
}
body,td{font-size:12px;color:#669900;font-family: MS Sans Serif, Tahoma, sans-serif, Bangkok;}
td.title{font-size:12px;color:#CCCCCC}
a{text-decoration:none}
a:link,a:visited{color:#FF3399;font-weight:normal}
a:hover{color:#99cc00}
a:active{color:#CCCCCC}
a.topmenu:link,a.topmenu:visited{color:#666666}
a.topmenu:hover{color:#FF6600}
a.topmenu:active{color:#555555}
//.style1 {color: #FF9900}

-->
</style>
</head>

<body>
<div align="left">
<font size="2" color="#FF6600">
<?php ssi_welcome(); ?>  <?php ssi_latestMember(); ?>
<br>
<?php ssi_recentPosts(); ?>
<br>
<?php ssi_logOnline(); ?>
</font>
</div>
</body>
</html>

เมื่อสร้าง showtopic.php และเพิ่มจะนวนที่จะโชว์กระทู้เสร็จแล้ว ตัวอย่าง<?php ssi_recentPosts(10); ?>
ก็ส่งขึ้น Host ได้เลย ออส่งไปไว้ใน Folders เดียวกับ Forum ได้เลยครับ หลังจากนั้นนำ Code ข้างล่างนี้ไปวางไว้ในหน้า Index ตามตำแหน่งที่ต้องการแล้วส่งขึ้น Host ตามปกติ

โค้ด: [เลือก]
<iframe name="I1"left border="0" frameborder="0" src="http://www.xxxx.com/forum/showtopic.php" target="_blank" height="289"   width="99%" style="color: #000000; border: 1px solid #FFFFFF; background-color: #FFFFFF"></iframe>เท่านี้ก็ใช้ได้แล้ว (มีปัญหา หรือได้ไม่ได้ช่วยบอกด้วยก็แล้วกันครับ)
« แก้ไขครั้งสุดท้าย: 26/08/09, 23:30:59 โดย chaotoob.com »

ออฟไลน์ TJorchid

  • New Member
  • *
  • กระทู้: 2
    • ดูรายละเอียด
Fatal error: Cannot redeclare ssi_shutdown() in /home/XXXXXXXX/domains/XXXXXX/public_html/webboard/SSI.php on line 190

ปัญหาคือดังนี้ล่ะครับ....

SSI.PHP บรรทัด 190 ก็คือ
function ssi_shutdown()

ออฟไลน์ valentine16

  • New Member
  • *
  • กระทู้: 5
    • ดูรายละเอียด
    <iframe name="I1"left border="0" frameborder="0" src="http://www.xxxx.com/forum/showtopic.php" target="_blank" height="289"   width="99%" style="color: #000000; border: 1px solid #FFFFFF; background-color: #FFFFFF"></iframe>


ไอ้ ด้านบนอะครับ เอาไปไช้แล้ว มันไม่ยอมไปหน้าใหม่เวลาคลิ๊กอะครับ ทำไงดี - -" มึนมากเลย เพราะเห็นในตัวมันมี target="_blank" รวมอยู่ด้วยแล้วนี่นา - -วอนผู้รู้ตอบที่ครับผม >.<