ติดต่อลงโฆษณา [email protected]

ผู้เขียน หัวข้อ: ตอนนี้ดึงกะทู้มาแสดงหน้าแรกได้ครับ แต่ต้องการให้ พอคลิกแล้วเปิดเป็นหน้าใหม่ครับ  (อ่าน 2957 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

โจ

  • บุคคลทั่วไป
ตอนนี้ดึงกะทู้มาแสดงหน้าแรกได้ครับ แต่ต้องการให้ พอคลิกแล้วเปิดเป็นหน้าใหม่ครับ
ไม่ทราบว่าแก้ยังครับ
ขอบคุณครับ

ออฟไลน์ TinaCat

  • Global Moderator
  • *****
  • กระทู้: 313
  • เพศ: หญิง
  • { Cat.Mazta }
    • ดูรายละเอียด
    • JustUsers.net
เอาโค้ดนี้ไปใส่ไว้ในส่วน <head>...</head> ในหน้าเว็บแสดงกระทู้ที่ทำขึ้นมาน่ะ

<base target="_blank">

เวลาคลิกลิงค์  ก็จะเปิดหน้าใหม่ให้เองทุกลิงค์


Don't laugh everytime you win, but smile when you be a loser.

โจ

  • บุคคลทั่วไป

ออฟไลน์ guanteen

  • Guanteen.com - กวนตีนที่สุดในโลก
  • New Member
  • *
  • กระทู้: 42
  • เพศ: ชาย
    • ดูรายละเอียด
    • กวนตีนที่สุดในโลก
ใช่เหรอเพ่ อันนี้มันเป็นทุกลิ้งนี่นา
เอาไปใส่ใน SSI.php
ในฟังก์ชัน ssi_recentTopics หรือ ssi_recentPosts (ใช้ find ในการค้นหา)
จากนี้
โค้ด: [เลือก]
<a href="', $post['href'], '">', $post['subject'], '</a>เปลี่ยนเป็น
โค้ด: [เลือก]
<a href="', $post['href'], ' target=_blank">', $post['subject'], '</a>

ออฟไลน์ nart_sk119

  • New Member
  • *
  • กระทู้: 3
    • ดูรายละเอียด
ใช่เหรอเพ่ อันนี้มันเป็นทุกลิ้งนี่นา
เอาไปใส่ใน SSI.php
ในฟังก์ชัน ssi_recentTopics หรือ ssi_recentPosts (ใช้ find ในการค้นหา)
จากนี้
โค้ด: [เลือก]
<a href="', $post['href'], '">', $post['subject'], '</a>เปลี่ยนเป็น
โค้ด: [เลือก]
<a href="', $post['href'], ' target=_blank">', $post['subject'], '</a>

ลองไปใส่ดูแล้วไม่เห็นจะเปิด Page ใหม่ให้เลยครับ

ออฟไลน์ guanteen

  • Guanteen.com - กวนตีนที่สุดในโลก
  • New Member
  • *
  • กระทู้: 42
  • เพศ: ชาย
    • ดูรายละเอียด
    • กวนตีนที่สุดในโลก
สมมุติว่าจะเรียกใช้ฟังก์ชั่นssi_recentPosts
เปิดไฟล์ SSI.php
ไปที่ฟังก์ชัน
โค้ด: [เลือก]
function ssi_recentPosts($num_recent = 8, $exclude_boards = null, $output_method = 'echo')
หาตรงนี้
โค้ด: [เลือก]
<a href="', $post['href'], '">', $post['subject'], '</a>
แล้วเปลี่ยนเป็น
โค้ด: [เลือก]
<a href="', $post['href'], '" [b]target="_blank[/b]">', $post['subject'], '</a>
ลองดูอีกทีครับ เพิ่ม target="_blank" อย่าลืมวรรคก่อนนะครับ ทำแบบนี้ทุกๆ ฟังก์ชั่นคงได้เหมือนกัน

ออฟไลน์ nart_sk119

  • New Member
  • *
  • กระทู้: 3
    • ดูรายละเอียด
ใส่แบบนี้ถูกต้องหรือเปล่าเพราะผมลองแล้วไม่ได้เหมือนเดิมอ่ะครับ

โค้ด: [เลือก]
echo '
<table border="0" class="ssi_table">';
foreach ($posts as $post)
echo '
<tr>
<td align="right" valign="top" nowrap="nowrap">
[', $post['board']['link'], ']
</td>
<td valign="top">
<a href="', $post['href'], '" target="_blank" >', $post['subject'], '</a>
', $txt[525], ' ', $post['poster']['link'], '
', $post['new'] ? '' : '<a href="' . $scripturl . '?topic=' . $post['topic'] . '.msg' . $post['new_from'] . ';topicseen#new"><img src="' . $settings['images_url'] . '/' . $context['user']['language'] . '/new.gif" alt="' . $txt[302] . '" border="0" /></a>', '
</td>
<td align="right" nowrap="nowrap">
', $post['time'], '
</td>
</tr>';
echo '
</table>';

ออฟไลน์ Friend-Service

  • New Member
  • *
  • กระทู้: 6
    • ดูรายละเอียด
ถ้าจะคลิกเปิดหน้าใหม่เอา code นี้ไปแทรก

โค้ด: [เลือก]
<base target="_blank">


ผมขอถามด้วยคับ ใครพอทราบว่าจะไห้มันเป็น font x-small บ้าง
นี่ code ของผม

<?php require("board/SSI.php"); ?>

<html>

<head>
<meta http-equiv="Content-Language" content="th">
<meta http-equiv="Content-Type" content="text/html; charset=tis-620">
<title>Show New Topics</title>
<base target="_blank">
</head>

<body bgcolor=#FFDAB9>
<?php ssi_recentTopics(20); ?>
<basefont color="#008080">
</body>

</html>


(เคยใส่ basefont size แล้วไม่ได้ผล)