ผู้เขียน หัวข้อ: คุณเก่งครับ ผมไม่สามารถพิมพ์ภาษาไทยยาว ๆ ได้เลยฮะ ไม่รู้เป็นเพราะอะไร  (อ่าน 10087 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ ppp

  • New Member
  • *
  • กระทู้: 6
    • ดูรายละเอียด
สวัสดีครับคุณเก่ง

ผมทำเวปไซต์ www.thaivwclub.com ฮะ เพิ่งจะเริ่มติดตั้ง SMF เวอร์ชั่น 1.1RC3 เข้าไปฮะ
แล้วอั๊พให้ภาษาไทยใช้ได้โดยทำดังนี้

ผมดาวน์โหลด ภาษาไทย จากในกระทู้นี้
http://smf.rcweb.net/index.php?topic=1092.0

โดยดาวน์โหลด   "thai-language-tis620-1.1-rc3.zip"
มาติดตั้งก่อน โดยผมติดตั้งลงไปใน 2 โฟลเดอร์คือ

ในโฟลเดอร์   /webboard ... โดยใช้การลงทับของเดิมไป
และอีกโฟลเดอร์ใน /webboard/Themes/Default ... ซึ่งก็ลงแบบทับของเดิมไปอีก

พอลงแล้วภาษาไทยก็เป็นตัวหนังสืออ่านไม่ออก
ผมก็ดาวน์โหลดไฟล์ "thai-language-utf8-1.1-rc3.zip" มาติดตั้งทับอีกที
โดยใช้วิธีเดิมคือ

ลงทับในโฟลเดอร์   /webboard
และลงทับอีกโฟลเดอร์ใน /webboard/Themes/Default

พอลงแล้ว ผมก็ไม่สามารถพิมพ์ข้อความยาวกว่า 34 ตัวอักรษรเป็นชื่อกระทู้ได้เลยฮะ
ไม่รู้ผมทำผิดพลาดตรงไหนรึเปล่า

รูปฮะ


ตรงนี้ด้วยครับ


ปล.ตามที่คุณเก่งโพสไว้เรื่องแปลงฐานข้อมูล
* วิธีแปลงฐานข้อมูลจาก TIS-620 ให้เป็น UTF-8 ให้เข้าไปที่ ผู้ดูแล/บำรุงรักษา
Convert HTML-entities to UTF-8 characters แล้วก็เลือก Proceed หลังจากนั้น เมนูภาษาไทยต่างๆ จะเป็นตัวอักษรที่อ่านไม่ได้ ให้ติดตั้งไฟล์ thai-language-utf8-1.1-rc3 เข้าไปหลังจากนั้นจึงจะใช้งานได้ตามปกติ

ผมไม่เห็นคำสั่ง Convert HTML-entities to UTF-8 characters เลยฮะ เมื่อเข้าไปที่ ผู้ดูแล/บำรุงรักษา แล้ว


ขอบคุณคุณเก่งที่แนะนำครับ
PAT (ppp) thaivwclub.com
« แก้ไขครั้งสุดท้าย: 31/10/06, 12:39:33 โดย ppp »

ออฟไลน์ КёngЯacing

  • Administrator
  • *****
  • กระทู้: 288
    • ดูรายละเอียด
เข้าไปที่ ผู้ดูแล/กระทู้และหัวข้อ
ในช่อง ยุติคำที่มีตัวอักษรมากกว่า ให้ใส่ 0
เนื่องจาก ถ้าเป็นบอร์ดภาษาต่างประเทศ แต่ละคำจะมีเว้นวรรคกัน แต่ภาษาไทย พิมพ์ประโยคยาวๆ ไม่มีเว้นวรรค มันก็เลยจะตัดคำที่เกินกว่าที่กำหนดไว้
« แก้ไขครั้งสุดท้าย: 31/10/06, 17:26:37 โดย КёngЯacing »

ออฟไลน์ ppp

  • New Member
  • *
  • กระทู้: 6
    • ดูรายละเอียด
ที่ตั้งเอาไว้ก็เป็น 0 อยู่นะครับคุณเก่งครับ
ผมลองตั้งให้เป็น 70 แล้ว หรือ 80 แล้วก็ไม่หายสักทีฮะ

ขอบคุณที่เข้ามาตอบฮะ  :D

ออฟไลน์ ppp

  • New Member
  • *
  • กระทู้: 6
    • ดูรายละเอียด
รูปฮะ



ผมพิมพ์ข้อความยาว ๆ เป็นหัวข้อกระทู้ได้ในเวปนี้ครับ
ผมสงสัยว่า มันอาจจะเป็นการตั้งค่าที่ผิดพลาด หรือตอนที่ผมติดตั้งภาาาไทยน่ะครับ
ไม่รู้ว่าเวลาลงภาษาไทย ต้องลงใน 2 โฟลเดอร์เลยรึเปล่าฮะ
คือ /webboard กับ /webboard/Themes/Default

ผมกำหนดสิทธิ์ให้คุณเก่งเป็นโมเดอเรเตอร์ในเวปผมฮะ ถ้าคุณเก่งอยากจะแก้อะไรบางอย่างครับ
ขอบคุณมากครับ  ;D

ออฟไลน์ КёngЯacing

  • Administrator
  • *****
  • กระทู้: 288
    • ดูรายละเอียด
อืม หาสาเหตุไม่เจอ หลังจากลองทดสอบในบอร์ดนี้

แต่โมเดอเรเตอร์ไม่สามารถปรับแต่งบอร์ดได้ครับ :)

คุณได้แก้ไขโค้ดบ้างหรือเปล่า อาการอย่างที่คุณเป็น คิดไม่ออกว่าเกิดจากอะไร แต่จำได้ว่าเคยเป็นนานแล้ว และแก้ไขยังไงก็ไม่รู้จำไม่ได้ซะอีก

ออฟไลน์ ppp

  • New Member
  • *
  • กระทู้: 6
    • ดูรายละเอียด
ผมปรับให้เป็น admin แล้วครับผม
ช่วยผมด้วยคร้าบบบ  :'(

ออฟไลน์ NuJanBaBor

  • New Member
  • *
  • กระทู้: 8
    • ดูรายละเอียด
ตอนเราใช้รุ่น  final
ต้องทำทั้งสองอย่างเลยคือ  Convert HTML-entities to UTF-8 characters

แล้วก็เปลี่ยนให้เป็น 0 ตรงกระทู้และหัวข้อ

โอเคมากๆๆๆๆๆๆ

ออฟไลน์ blueranchu

  • New Member
  • *
  • กระทู้: 24
    • ดูรายละเอียด
อาการผมก็เหมือนกัน
ย้ายดาต้าเบส เดิมใช้ smf 1.1 rc2 พอเปลี่ยนมาเป็น smf 1.1.1 หัวข้อกระทู้เดิมมันจะยาวๆๆ
แต่ถ้ากดโพส หรือตั้งกระทู้ใหม่ ข้อความจะถูกตัดหายไปครับ ช่วยแก้ด้วยครับ

ในช่อง ยุติคำที่มีตัวอักษรมากกว่า ให้ใส่ 0 ก็ไม่หายครับ
« แก้ไขครั้งสุดท้าย: 15/02/07, 11:12:24 โดย blueranchu »