ติดต่อลงโฆษณา [email protected]

ผู้เขียน หัวข้อ: พอมีวิธีไม่ให้ขึ้นชื่อบอร์ดตรงเฉพาะ header ไม๊ครับ  (อ่าน 2526 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

ออฟไลน์ BaLLaB

  • New Member
  • *
  • กระทู้: 27
    • ดูรายละเอียด
พอมีวิธีไม่ให้ขึ้นชื่อบอร์ดตรง header ไม๊ครับ

คือใช้ thmem แล้ว มะนจะขึ้นมา ทำให้ไม่สวย (ตรง บนสุดเลยอะคะบ ชื่อบอร์ด)

แต่พอทำแบบ ไม่ใช้ชื่อบอร์ดมันก็ทำให้ข้อมูลบางอย่างที่ต้องอาศัยชื่อบอร์ดมันแหว่งๆไปอะครับ

พอมีวิธีไม่ให้ขึ้นชื่อบอร์ดตรงเฉพาะ header ไม๊ครับ

ออฟไลน์ NUTKABPOM

  • Jr. Member
  • **
  • กระทู้: 88
  • เพศ: ชาย
    • ดูรายละเอียด
    • NUTKABPOM's Blog
อ่านแล้ว งงๆ ครับ

ลองแก้ในเทมเพลทดูน่ะครับ
ลองค้นหาหนทางด้วยตัวเอง เมื่อสำเร็จแล้วความภาคภูมิใจก็จะเป็นของคุณ

.....เล่นเกม คิดเองลองเองหรือให้เค้าใบ้แล้วคิดต่อ สนุกกว่า ดูเฉลย จริงมั้ย?

ออฟไลน์ BaLLaB

  • New Member
  • *
  • กระทู้: 27
    • ดูรายละเอียด
อธิบายใหม่เลยแล้วกัน

ด้านบนสุดของบอร์ด ตรงแถบที่มี logo ของ sF อยู่ด้านขวา ส่วนด้านซ้ายจะมีชื่อบอร์ดของเรา ซึ่งมันทำให้เกะกะครับ
แต่ถ้าเลือกที่จะไม่ใส่ชื่อบอร์ด ในส่วนของ ADMIN ส่วนอื่นๆที่ไม่ใช่ตรงนั้น แต่ต้องแสดงชื่อบอร์ดเช่น *** - ศูนย์กลางข้อมูล ตรง *** จะไม่ขึ้นชื่อบอร์ดครับ ซึ่งมันแหม่งๆ ครับ

พอมีวิธีที่ไม่ให้เฉพาะส่วนบนแสดงชื่อ อย่างเดียวไม๊ครับ โดยที่ส่วนอื่นๆ ยังคงแสดงชื่อบอร์ดอะครับ

ออฟไลน์ NUTKABPOM

  • Jr. Member
  • **
  • กระทู้: 88
  • เพศ: ชาย
    • ดูรายละเอียด
    • NUTKABPOM's Blog
ไปแก้ใน index.template.php ดูน่ะครับ

ลอง find คำว่า <body> ดูน่ะ

อ้างถึง
<body>';

   echo '
   <div class="tborder" ', $context['browser']['needs_size_fix'] && !$context['browser']['is_ie6'] ? ' style="width: 100%;"' : '', '>
      <table width="100%" cellpadding="0" cellspacing="0" border="0">
         <tr>
            <td class="catbg" height="32">';

   if (empty($settings['header_logo_url']))
      echo '
               <span style="font-family: MS Sans Serif, Tahoma, Thonburi, Bangkok; font-size: 140%; ">', $context['forum_name'], '</span>';

   else
      echo '
               <img src="', $settings['header_logo_url'], '" style="margin: 4px;" alt="', $context['forum_name'], '" />';

   echo '
            </td>
            <td align="right" class="catbg">
               <img src="', $settings['images_url'], '/smflogo.gif" style="margin: 2px;" alt="" />
            </td>
         </tr>
      </table>';

ลองเอาตรงสีแดงออกดูน่ะครับ
ลองค้นหาหนทางด้วยตัวเอง เมื่อสำเร็จแล้วความภาคภูมิใจก็จะเป็นของคุณ

.....เล่นเกม คิดเองลองเองหรือให้เค้าใบ้แล้วคิดต่อ สนุกกว่า ดูเฉลย จริงมั้ย?

ออฟไลน์ BaLLaB

  • New Member
  • *
  • กระทู้: 27
    • ดูรายละเอียด
ขอบคุณครับ แต่ เออ อยากบอกว่า หาไม่เจอครับ เหอะๆ

ออฟไลน์ NUTKABPOM

  • Jr. Member
  • **
  • กระทู้: 88
  • เพศ: ชาย
    • ดูรายละเอียด
    • NUTKABPOM's Blog
หาอะไรไม่เจอครับ ไฟล์ หรือ โค๊ต

ถ้าไฟล์ มันจะอยู่ใน \Themes\default ครับ ชื่อไฟล์ index.template.php

้ถ้าโค๊ต จะอยู่บรรทัดที่ 177 ในไฟล์ index.template.php ครับ
ลองค้นหาหนทางด้วยตัวเอง เมื่อสำเร็จแล้วความภาคภูมิใจก็จะเป็นของคุณ

.....เล่นเกม คิดเองลองเองหรือให้เค้าใบ้แล้วคิดต่อ สนุกกว่า ดูเฉลย จริงมั้ย?

ออฟไลน์ BaLLaB

  • New Member
  • *
  • กระทู้: 27
    • ดูรายละเอียด
ไปแก้ใน index.template.php ดูน่ะครับ

ลอง find คำว่า <body> ดูน่ะ

อ้างถึง
<body>';

   echo '
   <div class="tborder" ', $context['browser']['needs_size_fix'] && !$context['browser']['is_ie6'] ? ' style="width: 100%;"' : '', '>
      <table width="100%" cellpadding="0" cellspacing="0" border="0">
         <tr>
            <td class="catbg" height="32">';

   if (empty($settings['header_logo_url']))
      echo '
               <span style="font-family: MS Sans Serif, Tahoma, Thonburi, Bangkok; font-size: 140%; ">', $context['forum_name'], '</span>';

   else
      echo '
               <img src="', $settings['header_logo_url'], '" style="margin: 4px;" alt="', $context['forum_name'], '" />';

   echo '
            </td>
            <td align="right" class="catbg">
               <img src="', $settings['images_url'], '/smflogo.gif" style="margin: 2px;" alt="" />
            </td>
         </tr>
      </table>';

ลองเอาตรงสีแดงออกดูน่ะครับ

ได้แล้วครับ

ขอบคุณครับ  :)

แต่ว่า ถ้าเปลี่ยนตรงนั้น มันใช้ไม่ได้กับทุกๆ theme นะครับ บาง theme ก็ใช้ได้ บางอันก็จะ error ครับ (บอร์ดผม มี 2 บอร์ดครับ อันนึงใช้ได้ อีกอันจะบอก templete error ครับ)
« แก้ไขครั้งสุดท้าย: 20/10/06, 09:15:50 โดย BaLLaB »