SMF Development > SMF Coding Discussion

ลง mod แล้ว error ครับ

(1/3) > >>

Heartbreaker:
ผมลง mod User Online Today 1.3.1 สำหรับ 1.1rc2 ครับ
โดย ศุนยืจัดการแพคเกจ พอลงแล้วกำลังจะ ติดตั้ง มันขึ้นข้อความอย่างนี้อ่ะคับ

Error in Package Installation

At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.

1. Execute Modification Users_Online_Today_Mod.xml Modification parse error
2. Execute Modification -                                                              Modification parse error

จะติดตั้งต่อไปแล้วจะมีปัญหาไหมครับ แล้วแก้ไขยังงัย ช่วยหน่อยนะคับ

TinaCat:
ก่อนหน้านี้เคยลง Mod User Online เวอร์ชั่นเก่ารึป่าวคะ??
ถ้าเคยก็ Uninstall ออกก่อนค่ะ
แล้วค่อยทำการติดตั้งเวอร์ชั่นใหม่อีกทีค่ะ

Heartbreaker:
เคยลง mod Shout Box ครับ
แต่พอดาวน์โหลดมาแล้ว ไม่ได้ apply ครับ
เลย delete ตัวนี้ทิ้ง
1.1rc2  มี mod ตัวนี้ไว้แล้วหรือปล่าวครับ

พอผมลอง appy มันขึ้นแบบนี้อ่าครับ  แก้ไม่เป็น

Fatal error: PackageInstall() [function.require]: Failed opening required '/forums/Packages/temp/./shoutPdb.php' (include_path='.:/usr/share/php5:/usr/share/php') in /forums/Sources/Packages.php on line 534

TinaCat:

--- อ้างจาก: Heartbreaker ที่ 12/01/06, 11:28:00 ---พอผมลอง appy มันขึ้นแบบนี้อ่าครับ  แก้ไม่เป็น

Fatal error: PackageInstall() [function.require]: Failed opening required '/forums/Packages/temp/./shoutPdb.php' (include_path='.:/usr/share/php5:/usr/share/php') in /forums/Sources/Packages.php on line 534
--- ปิดอ้างถึง ---

สร้างโฟลเดอร์ temp ไว้ในไดเรคทอรี่ Packages ก่อนค่ะ
และเซ็ต CHMOD เป็น 777 ด้วยนะคะ  (ทั้ง Packages และ temp)
แล้วค่อยลองติดตั้ง Mod อีกที

Ultimate Shoutbox สำหรับ SMF 1.1 RC2 ก็มีแล้วค่ะ
http://mods.simplemachines.org/index.php?mod=22

ส่วน Mod User Online
ถ้าไม่เคยลง Mod ตัวนี้เวอร์ชั่นเก่า  แต่ก็ยังติดตั้งไม่ได้  (ถ้าแน่ใจว่าใช้ Mod ตรงเวอร์ชั่นกับ SMF แล้ว)
ลองอัพโหลดไฟล์ชุด Sources ขึ้นโฮสต์อีกทีนะคะ  (ในกรณีที่คุณไม่เคยลง Mod หรือแก้ไขอะไรในไฟล์ชุดนี้เลย)
แล้วค่อยลอง Install Mod อีกครั้ง

หรือลองเปิดไฟล์ .xml  ไล่ดูโค้ด  แล้วทำการติดตั้งเองค่ะ

Heartbreaker:
ผมจะลองดุอย่างที่คุณ TinaCat บอกนะครับ
ถ้ามีปัญหายังงัย ก้มาบอกอีกนคระบ
ขอบคุรคับ

นำร่อง

[0] ดัชนีข้อความ

[#] หน้าถัดไป

ไปที่เวอร์ชันเต็ม